Olex2-1.3 MacOS: Olex2 won't open after update

Olex2 related issues, ideas, troubleshooting and of course general Olex2 related tomfoolery its all good and welcome. Linux, Mac even Windows all goes in here

Link: Olex2 Homepage

Moderators: oleg, HorstPuschmann

htisdale
Posts: 2
Joined: 31 May 2021, 00:40

Olex2-1.3 MacOS: Olex2 won't open after update

Post by htisdale » 31 May 2021, 01:35

I recently updated by MacOS to Big Sur 11.4 from 11.3. I had Olex2-1.3 installed and working in 11.3 but after the update it will not open (an error is given that the program "closed unexpectedly" even though it never fully opened). Reinstalling Olex2-1.3 does not work. However, opening Olex2-1.3 from the Downloads folder works perfectly. When I try to open it from the Applications folder with the terminal, it opens this window (this is exactly how I see it, minus the black bars censoring my name):

Image

Any advice?

User avatar
oleg
Olex2 Boffin
Posts: 835
Joined: 24 Nov 2008, 21:34

Re: Olex2-1.3 MacOS: Olex2 won't open after update

Post by oleg » 02 Jun 2021, 18:46

I am not sure as I try to postpone Mac update for a while as it sometimes modifies the firmware and it becomes impossible to roll back and some people do not update their systems and it then makes builds on the old systems incompatible.

You can always run Olex2 in an old 'Unix' way - in terminal - cd to the olex2.app/Contents/MacOS and do ./olex2 - this seems to resolve problems sometimes.

A similar (?) report for the Mac update:
https://gitlab.com/olexsys/olex2-support/-/issues/147
but I am not sure if these are related...

htisdale
Posts: 2
Joined: 31 May 2021, 00:40

Re: Olex2-1.3 MacOS: Olex2 won't open after update

Post by htisdale » 05 Jun 2021, 19:08

I FIGURED OUT THE ISSUE! Apparently, the newest MacOS update has changed how it handles hyphens in directory names. The applications folder that I was trying to run was "olex2-1.3.app", and it would not open. However, once I changed it to "olex2 1.3.app" (space instead of hyphen), it opened and worked without issue. I guess the next olex2 MacOS update just needs to get rid of the hyphen.

Thanks Oleg!

Return to “Olex2”