New RPM's for SuSE, fedora, centos and ubuntu

A Bord for users of MolIso
Link: Moliso Homepage

Moderator: chuebsch

User avatar
chuebsch
300th member
Posts: 88
Joined: 10 Nov 2009, 18:56
Location: Bayreuth

New RPM's for SuSE, fedora, centos and ubuntu

Post by chuebsch » 19 Nov 2009, 10:30

:wav: :wav: :wav:
There are new RPM's for SuSE on the download page
and there are some for fedora and centos more on http://www.debroglie.net.
You can find all links on the Moliso download page.
:wav: :wav: :wav:

User avatar
bimba
Posts: 4
Joined: 20 Nov 2009, 15:15

Re: New RPM's for SuSE on the download page

Post by bimba » 21 Nov 2009, 10:19

Nice, but where is the (K)Ubuntu version? :angryfire:
Image

User avatar
chuebsch
300th member
Posts: 88
Joined: 10 Nov 2009, 18:56
Location: Bayreuth

Re: New RPM's for SuSE on the download page

Post by chuebsch » 04 Dec 2009, 19:31

Hi bimba,

I have good news for you:

http://www.moliso.de/moliso_2.0.5-1_i386.deb

is now at http://www.moliso.de/download.html
open it with:
gdebi-kde or
gdebi-gtk :occasion5: :occasion5: :occasion5:

cheers
christian

User avatar
bimba
Posts: 4
Joined: 20 Nov 2009, 15:15

Re: New RPM's for SuSE, fedora, centos and ubuntu

Post by bimba » 04 Dec 2009, 22:03

Yeah, :headbang:

great now I can start MolIso on Kubuntu from the start menu. Sorry for :protest:

:violent1: :lovestory: :laughing3:


...thank you!
Image

davide

Re: New RPM's for SuSE, fedora, centos and ubuntu

Post by davide » 11 May 2010, 09:56

Hi there,
I've an ubuntu 64bit release the last long release( 10.04 lucid)

this is my operative system:
Linux davide-laptop 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux

I tried to install the deb package forcing the 386 architecture.
it seems everything go well:

davide@davide-laptop:~$ sudo dpkg --force-architecture -i moliso_2.0.5-1_i386.deb
[sudo] password for davide:
dpkg: error processing moliso_2.0.5-1_i386.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
moliso_2.0.5-1_i386.deb
davide@davide-laptop:~$ sudo dpkg --force-architecture -i moliso_2.0.5-1_i386.deb
dpkg: warning: overriding problem because --force enabled:
package architecture (i386) does not match system (amd64)
(Reading database ... 251190 files and directories currently installed.)
Preparing to replace moliso 2.0.5-1 (using moliso_2.0.5-1_i386.deb) ...
Unpacking replacement moliso ...
Setting up moliso (2.0.5-1) ...

Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_GB.utf8.cache...
Processing triggers for desktop-file-utils ...
Processing triggers for menu ...
Processing triggers for python-support ...

but when I try to run moliso it doesn't work :cry:

do you have any suggestion?
thanks :wave:

User avatar
chuebsch
300th member
Posts: 88
Joined: 10 Nov 2009, 18:56
Location: Bayreuth

Re: New RPM's for SuSE, fedora, centos and ubuntu

Post by chuebsch » 12 May 2010, 08:03

Welcome Davide!

Although I do not know why it is not working on your machine, here is an alternative
Download the source:
http://www.moliso.de/moliso-2.0.5.tar.bz2

change to the directory where your downloaded file is and run
tar xvjf moliso-2.0.5.tar.bz2

Code: Select all

chuebsch@ewald:/media/disk-1> tar xvjf moliso-2.0.5.tar.bz2
moliso-2.0.5/
moliso-2.0.5/plane.h
moliso-2.0.5/AVIGenerator.h
moliso-2.0.5/Doc/
moliso-2.0.5/Doc/normal.eps
moliso-2.0.5/Doc/sheerplan.eps
moliso-2.0.5/Doc/Manual.tex
moliso-2.0.5/Doc/ac.eps
moliso-2.0.5/Doc/title.eps
moliso-2.0.5/Doc/Menustrukture.jpg.bb
moliso-2.0.5/Doc/g1.eps
moliso-2.0.5/Doc/front.eps
moliso-2.0.5/Doc/Menustrukture.jpg
moliso-2.0.5/COPYING
moliso-2.0.5/isochange.h
moliso-2.0.5/isosurf.h
moliso-2.0.5/gluthack.h
moliso-2.0.5/LICENSE
moliso-2.0.5/molekul.h
moliso-2.0.5/resource.h
moliso-2.0.5/moliso.cpp
moliso-2.0.5/about.h
moliso-2.0.5/moliso.desktop
moliso-2.0.5/gl2ps.c
moliso-2.0.5/moliso.xpm
moliso-2.0.5/AVIGenerator.cpp
moliso-2.0.5/README
moliso-2.0.5/gl2ps.h
moliso-2.0.5/example/
moliso-2.0.5/example/xd_esp.grd
moliso-2.0.5/example/moliso.ini
moliso-2.0.5/example/xd_esp.cube
moliso-2.0.5/example/xd_rho.grd
moliso-2.0.5/example/sph5.ppm
moliso-2.0.5/example/xd.mas
moliso-2.0.5/example/sph5d.ppm
moliso-2.0.5/example/xd_rho.cube
moliso-2.0.5/example/xd.res
moliso-2.0.5/example/moliso_cube.ini
moliso-2.0.5/example/Atomcolors.dat
moliso-2.0.5/Makefile
run:
make

Code: Select all

chuebsch@ewald:/media/disk-1/moliso-2.0.5> make
g++  -Wall -pedantic moliso.cpp gl2ps.c -I/usr/X11R6/include -L/usr/X11R6/lib64 -lglut -lGLU -lGL -Dx86_64 -o moliso
copy moliso to a propriate binary directory eg: $HOME/bin/ or /usr/bin/

If anything goes wrong please tell me
Christian

davide

Re: New RPM's for SuSE, fedora, centos and ubuntu

Post by davide » 12 May 2010, 13:27

Hi,
thanks for the very quick reply.
unlucky there is a problem, something is missing in my laptop :(

davide@davide-laptop:~/moliso-2.0.5$ make
g++ -Wall -pedantic moliso.cpp gl2ps.c -I/usr/X11R6/include -L/usr/X11R6/lib -lglut -lGLU -lGL -o moliso
/usr/bin/ld: cannot find -lGL
collect2: ld returned 1 exit status
make: *** [all] Error 1
davide@davide-laptop:~/moliso-2.0.5$

looking the /usr/ directory I discovered there is not the usr/X11R6/include path so I guess this is the problem.

davide@davide-laptop:~/moliso-2.0.5$ ls /usr
bin games include lib lib32 lib64 local sbin share src

So I try to solve by myself but I wasn't able. :cry:
In detail I found there is an usr/include/X11 directory and /usr/lib64/X11
I changed the path inside the Makefile but it said:

davide@davide-laptop:~/moliso-2.0.5$ make
g++ -Wall -pedantic moliso.cpp gl2ps.c -I/usr/include/X11 -L/usr/lib/X11/ -lglut -lGLU -lGL -o moliso
/usr/bin/ld: cannot find -lGL
collect2: ld returned 1 exit status
make: *** [all] Error 1


I not expert at all in graphics program and openGl but I guess the problem is this kind of stuff, don't it?

User avatar
chuebsch
300th member
Posts: 88
Joined: 10 Nov 2009, 18:56
Location: Bayreuth

Re: New RPM's for SuSE, fedora, centos and ubuntu

Post by chuebsch » 12 May 2010, 13:42

Well I'm not an expert in ubuntu I'm more familiar with SuSE. :blackeye:

Do you have an 3D graphics card driver installed?

What is you the name of your card?

What does 'glxinfo' tell you?

I think you need some packages like 'libglut-dev' I don't know if this is the right name.
the header files of OpenGL should be found here:
/usr/include/GL/


Cheers
Christian

davide

Re: New RPM's for SuSE, fedora, centos and ubuntu

Post by davide » 12 May 2010, 16:23

yes, I've got a NVIDIA and, obviously, I've the driver installed.
by the way glxinfo:

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
GLX_EXT_swap_control, GLX_EXT_texture_from_pixmap, GLX_ARB_create_context,
GLX_ARB_create_context_profile, GLX_ARB_multisample, GLX_NV_float_buffer,
GLX_ARB_fbconfig_float, GLX_EXT_framebuffer_sRGB
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,
GLX_NV_swap_group, GLX_NV_video_out, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGI_swap_control, GLX_EXT_swap_control, GLX_ARB_create_context,
GLX_ARB_create_context_profile, GLX_NV_float_buffer,
GLX_ARB_fbconfig_float, GLX_EXT_fbconfig_packed_float,
GLX_EXT_texture_from_pixmap, GLX_EXT_framebuffer_sRGB,
GLX_NV_present_video, GLX_NV_copy_image, GLX_NV_multisample_coverage,
GLX_NV_video_capture
GLX version: 1.4
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
GLX_EXT_swap_control, GLX_EXT_texture_from_pixmap, GLX_ARB_create_context,
GLX_ARB_create_context_profile, GLX_ARB_multisample, GLX_NV_float_buffer,
GLX_ARB_fbconfig_float, GLX_EXT_framebuffer_sRGB,
GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 8600M GS/PCI/SSE2
OpenGL version string: 3.2.0 NVIDIA 195.36.15

OpenGL shading language version string: 1.50 NVIDIA via Cg compiler
OpenGL extensions:
GL_ARB_color_buffer_float, GL_ARB_compatibility, GL_ARB_copy_buffer,
GL_ARB_depth_buffer_float, GL_ARB_depth_clamp, GL_ARB_depth_texture...

plus more other stuff....
concerning the libglut-dev the name is correct and I've got it:
davide@davide-laptop:~$ sudo apt-get install libglut3
libglut3 libglut3-dev
davide@davide-laptop:~$ sudo apt-get install libglut3
Reading package lists... Done
Building dependency tree
Reading state information... Done
libglut3 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
davide@davide-laptop:~$ sudo apt-get install libglut3-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
libglut3-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
davide@davide-laptop:~$

and also I think everything should be here:
Building dependency tree
Reading state information... Done
libglut3 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
davide@davide-laptop:~$ sudo apt-get install libglut3-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
libglut3-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
davide@davide-laptop:~$ clear









davide@davide-laptop:~$ ls /usr/include/GL/
freeglut_ext.h glext.h glu.h glxext.h glx_mangle.h glxtokens.h
freeglut.h gl.h glu_mangle.h glx.h glxmd.h internal
freeglut_std.h gl_mangle.h glut.h glxint.h glxproto.h
davide@davide-laptop:~$

:angryfire:
I'm asking also in the ubuntu's forum, if I'll try the solution I'll tell you :color:

User avatar
chuebsch
300th member
Posts: 88
Joined: 10 Nov 2009, 18:56
Location: Bayreuth

Re: New RPM's for SuSE, fedora, centos and ubuntu

Post by chuebsch » 12 May 2010, 17:40

Code: Select all


chuebsch@ewald:/media/disk-1/moliso-2.0.5> ls /usr/include/GL/
dmesa.h         freeglut_std.h  glfbdev.h    glu.h         glxext.h  glx_mangle.h  glxtokens.h  mglmesa.h   vms_x_fix.h
freeglut_ext.h  ggimesa.h       gl.h         glu_mangle.h  glx.h     glxmd.h       internal     osmesa.h    wglext.h
freeglut.h      glext.h         gl_mangle.h  glut.h        glxint.h  glxproto.h    mesa_wgl.h   svgamesa.h  wmesa.h

is there a package called libgl-dev?

I'm always installing the NVIDIA driver
http://www.nvidia.de/content/DriverDown ... 4-pkg2.run
line this:
sudo sh NVIDIA-Linux-x86_64-195.36.24-pkg2.run
And I thought this also installs the GL stuff, but may be I'm wrong.

Have a nice holiday (at least in Germany we have one tomorrow)
Cheers Christian

davide

Re: New RPM's for SuSE, fedora, centos and ubuntu

Post by davide » 17 May 2010, 13:46

Hi,
sorry if I didn't wrote but as in German the last Thursday was holiday in Bern and on Friday I was a bit busy.
I've got some news.
I installed the last NVIDIA drivers and with this, I guess also the openGl libraries were missing.
so now I can compile the make file :iconbiggrin:


davide@davide-laptop:~/moliso-2.0.5$ make
g++ -Wall -pedantic moliso.cpp gl2ps.c -I/usr/X11R6/include -L/usr/X11R6/lib -lglut -lGLU -lGL -o moliso

the bad news is moliso still doesn't run :cry:

maybe this error say you something:

davide@davide-laptop:~/moliso-2.0.5$ ./moliso
sh: kdialog: not found

User avatar
chuebsch
300th member
Posts: 88
Joined: 10 Nov 2009, 18:56
Location: Bayreuth

Re: New RPM's for SuSE, fedora, centos and ubuntu

Post by chuebsch » 17 May 2010, 13:58

Ok sounds good kdialog is probably the last package you have to install. And then moliso will run on your machine. If you want to test you can start it in a directory with a moliso.ini file then you do not need kdialog (if all paths in the moliso.ini file are correct).

Cheers
Christian

davide

Re: New RPM's for SuSE, fedora, centos and ubuntu

Post by davide » 17 May 2010, 16:05

YES!!!!!!!
at last it works!!!!!
:compress: :shaking2: :evil4: :toothy8: :toothy10: :toothy6: :tongue3:

thanks a lot!

Cheers
Davide

Return to “MolIso”